vagrant 를 사용하려면 virtualbox 를 먼저 설치해야 한다.

우분투에서는 apt 패키지로 설치하면 편하다.

관련 링크 : https://www.virtualbox.org/wiki/Linux_Downloads 


apt-key 등록 , apt update 시에 다음과 같은 에러가 나오는 경우가 있다.

W: bzip2:/var/lib/apt/lists/partial/download.virtualbox.org_virtualbox_debian_dists_trusty_contrib_binary-amd64_Packages 파일을 받는데 실패했습니다  해시 합이 맞지 않습니다

W: bzip2:/var/lib/apt/lists/partial/download.virtualbox.org_virtualbox_debian_dists_trusty_contrib_binary-i386_Packages 파일을 받는데 실패했습니다  해시 합이 맞지 않습니다


apt 캐시를 삭제(clean) 해주고,  /var/lib/apt/lists 쪽도 삭제를 한후 다시 시도해본다.

# apt-get clean

# rm /var/lib/apt/lists/*
rm: `/var/lib/apt/lists/partial'를 지울 수 없음: 디렉터리입니다

# rm /var/lib/apt/lists/partial/*

# apt-get clean

# apt-get update


뭔가 안된다.

이게 아닌가?

네트웍이 불안해서 그런가?
    => 이게 답인 것 같다. 지금 해보니 해당 에러가 없어졌다.


신고

댓글을 달아 주세요