LTS 버전이 14.04 가 나온지 1년이 넘었는데

아직 10.04 를 쓰고 있는 서버들이 있다. 바로 14.04 로 올리긴 이슈가 발생할 것 같아서
소극적으로 12.04 로 먼저 업그레이드 할 예정이다.
지원기간이 2017녀까지이니, 아직 여유가 있다.(10.04 는 지원기간이 지났다)

do-release-upgrade

로 업그레이드 하면 된다.


배포판 업그레이드는 지금까지 특이사항 없이 잘 했었다.
그런데, 이번에는 다음과 같은 에러를 보게 되었다.(특정서버에서 발생)

E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages

업그레이드 시작전에 체크하면서 오류가 발생한 듯 하다.


확인해보니 ibus-hangul 패키지가 깨진 듯 하다.

확인은 /var/log/dist-upgrade/apt.log 파일을 확인해본다.

Broken 패키지를 찾아보면 된다.

apt-get remove ibus-hangul

명령으로 제거를 한 후 다시 업그레이드 하니 진행이 잘 된다




신고

댓글을 달아 주세요