추가: python 2.5 로 다운그레이드해서 쓰니 다른문제들이 더 많다.
  python 2.6 에서 작동하도록 수정하는 것이 더 쉽다.
  python 2.6 에서 sysmon 사용하는 것은 따로 포스팅 예정.


sysmon 으로 서버모니터링을 해볼까 테스트하는데.
ubuntu 10.04 에서 python 2.6 이 깔려있는데, sysmon 이 오류를 뿜어낸다.
2.5 로 다운그레이드를 해야 겠다.

이미 시도한 분들이 있다.
http://yoophi.sshel.com/wp/?p=164
http://kovshenin.com/archives/installing-python-2-5-on-ubuntu-linux-10-10/

$ sudo add-apt-repository ppa:fkrull/deadsnakes
$ sudo apt-get update
$ sudo apt-get install python2.5
add-apt-repository 명령이 없다면, 아래 명령으로 패키지를 설치해주면된다.
sudo apt-get install python-software-properties


launchpad 의 패키지를 사용하는 방법.
첫줄을 수동으로 할려면 /etc/apt/sources.list 에 다음줄을 넣어준다.
deb http://ppa.launchpad.net/fkrull/deadsnakes/ubuntu lucid main
deb-src http://ppa.launchpad.net/fkrull/deadsnakes/ubuntu lucid main

sysmon 이 잘 작동해야 할텐데. 근데, sysmon 설명이 참 부실하다.

반응형

WRITTEN BY
1day1
하루하루 즐거운일 하나씩, 행복한일 하나씩 만들어 가요.

트랙백  0 , 댓글  0개가 달렸습니다.
secret